ULTRAM VCO

G8GKQ
Site Admin
Posts: 595
Joined: Sun Mar 22, 2009 1:21 pm

Re: ULTRAM VCO

Postby G8GKQ » Thu Apr 24, 2014 2:31 pm

I'm trying to program a 437 MHz Ultram VCO from a Raspberry Pi. The parameters that I am using (from G8AJN's excellent website) are:

Control: 06E124
R counter: 000029
N counter: 003616

I only seem to be able to make the VCO free-run at about 470MHz, although I can make it divide that by 2, or shutdown the VCO, by sending the appropriate codes. I've tried other code combinations, but with no luck.

Edit - I've just soldered the original PIC back and the VCO runs at 437 MHz - so I haven't killed it!

2nd Edit - I have sniffed the codes from the PIC and the ones above are correct. It seems that I have a problem with my Raspberry Pi SPI implementation. Code corrections to follow!


Dave
G8GKQ

VK5YYY
Posts: 43
Joined: Sun Sep 27, 2015 1:47 am

Re: ULTRAM VCO

Postby VK5YYY » Mon Feb 01, 2016 12:55 am

This is our effort in a Hammond box
It's a great little unit
(the 20Khz error is the analyser and 30db attenuator in line so actually +10dbm output)
Thanks for your help Dave!
All we need now is a knob we can spin to adjust the output level
I see on Ebay here one with a touch screen and sweep function on special $66US
http://www.ebay.com.au/itm/301848410976 ... EBIDX%3AIT
Guess not as clean as Ultram
Attachments
WP_000595.jpg
Ultram in Hammond box
WP_000595.jpg (101.39 KiB) Viewed 1225 times


Return to “DigiLite”

Who is online

Users browsing this forum: No registered users and 2 guests