Problem getting new update online - no internet

Discussion about this major DATV Project. See also https://wiki.batc.tv/The_Portsdown_Transmitter
KenW6HHC
Posts: 227
Joined: Mon Jun 01, 2009 4:20 pm

Problem getting new update online - no internet

Postby KenW6HHC » Mon Apr 17, 2017 6:18 pm

I seem to be having no success in performing an online update of the Portsdown software via SSH MENU. It appears that I can NOT reach internet even though SSH MENU shows RPi-3 wifi is connected to my home wifi Access Point?

Just to confirm my set-up
* Portsdown-RPi-3-DATV-Express
* current Portsdown release being used 201702190 (BATC produced SD memory)
* Ethernet router works well with SSH - BUT HAS NO ETHERNET connection (I am assuming this is OK...since router is only intended to work on putty cables.)
* RPi-3 wifi is connected to my home Access Point.

Image
Current RPi-3 interface file
I have been assuming that the RPi-3 "interface" file shown above is OK for my set-up and does NOT need any adjustments?

Image
SSH MENU shows RPi-3 wifi is connected to my home SSID OK via wlan0.
The RPi-3 ping shows 37 pings sent to Google...no responses were received.


The RPi-3 is acting as if it is trying to ping on the putty router-with-Ethernet-cables...and NOT via wifi on RPi-3 on wlan0?

When I try to do a SSH MENU software update...the update process fails and explains that "unable to resolve host address "raw.github..." and eventually just says "unable to get to Internet".

Does any experienced putty/RPi-3 user out there see the root-cause of the internet-access problem that I am experiencing?

Thank you for any assistance/guidance...de KenW6HHC

G8GKQ
Site Admin
Posts: 480
Joined: Sun Mar 22, 2009 1:21 pm

Re: Problem getting new update online - no internet

Postby G8GKQ » Tue Apr 18, 2017 9:08 am

Hi Ken

Looks to be a pure RPi networking or ISP problem as you're still seeing it outside the Portsdown software. Apart from setting up the Wifi, the Portsdown software does not change the default network set-up. Please run the following commands and post the results:

Code: Select all

netstat -rn
and then:

Code: Select all

ifconfig

I take it that your PC is on the wireless network as well and there is nothing plugged into the RPi's network port?

73, Dave

KenW6HHC
Posts: 227
Joined: Mon Jun 01, 2009 4:20 pm

Re: Problem getting new update online - no internet

Postby KenW6HHC » Thu Apr 20, 2017 4:54 pm

Hi Dave G8GKQ,

1) Yes my Dell notebook is on wifi too. (NO ETHERNET cables used in my house…except from the cable-ISP-modem straight to my desktop PC.)
2) The only ethernet cable plugged into the RPi's network port is for putty communications.

It looks like my LinkSys wifi router is conflicting with my ISP wifi. On fresh power-up, Dell notebook wifi works OK (using wifi to my home ISP AP). But as soon as I plug putty ethernet cable into the Dell notebook, the wifi on Dell notebook STOPS working properly (almost nothing works). I spent 75 minutes on phone with AT&T tech support and they ran a number of tests, and said my Access Point is working properly. I have another older Dell notebooks that works properly with home wifi AP. BTW…the putty Dell notebook wifi is NOT totally dead…but very impacted. For example, from Dell I can see Google from Dell browser…but none of links that Google displays after a search will work.

Image
IP-Scanner shows RPi-3 interfaces of 192.168.1.201 and 192.168.1.73 (wi-fi assigned by my home AP)

Image
RPi-3 ifconfig results

Image
RPi-3 netstat results
I do NOT see any obvious problems, yet…but it has been many years since I worked on network configurations.

I suspect that I can eliminate wifi conflict…if I can totally disable the wifi on my old LinkSys model WRT54GS router used for putty…but, I have not succeeded in doing that yet?

Any suggestions.

73…de Ken W6HHC

G8GKQ
Site Admin
Posts: 480
Joined: Sun Mar 22, 2009 1:21 pm

Re: Problem getting new update online - no internet

Postby G8GKQ » Thu Apr 20, 2017 9:03 pm

OK Ken

As your Laptop is connected to your WiFi, and the RPi is connected to WiFi, there is no need to connect a network cable between the 2. Indeed - I think it is what is causing your problems.

So, disconnect the network cable, and reboot both your laptop and the RPi. Then use Putty on the laptop to connect to the RPi on 192.168.1.73 (your RPi's address on WiFi). From there, it should all work.

It looks like the RPi was trying to get to the internet through your Laptop using the network cable (which it wouldn't be able to do), rather than using the WiFi like it needed to.

Hope that works - let me know

Dave

KenW6HHC
Posts: 227
Joined: Mon Jun 01, 2009 4:20 pm

Re: Problem getting new update online - SUCCESS

Postby KenW6HHC » Fri Apr 21, 2017 1:31 pm

Hi Dave G8GKQ,

UPDATE SUCCESS! The change you suggested to eliminate the putty ethernet cables and have putty go straight to the RPi-3 wifi IP-address worked. My wifi conflict is resolved and the Portsdown update succeeded. I should have known something was conflicted when the prompt for the Pi password always took a long time to appear…something was timing out? Now, the password prompt appears instantly. I still have my notebook talking to my home wifi AP and the RPi-3 talking to my home wifi AP. The conflict was being caused by my LinkSys router that had both ethernet and wifi.

Image
Portsdown update 201704160 now installed after IP issue resolved

The touch screen GUI has changed and the display is functioning differently….so now I need to read up on how the displays work in this release.

Thank you for all your help…de Ken W6HHC


Return to “The Portsdown Digital Transmitter Project”

Who is online

Users browsing this forum: No registered users and 2 guests